Volkswagen Automobiles Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
1,047 Posts
Discussion Starter · #1 ·
where do i start??

1. engine workshop shows up and the glow plug light is flashing only sometimes but im going to get it plugged in

2. Brake lights are staying on so went and replaced the switch at the pedal and now its only sometimes it stays on.

3. noticed the brakes were making a bit of noise but today coming home on the m50 doing 100kph i braked and it felt and sounded like i was going over rumble strips

4. afaik the egr is deleted in the car but sometimes the turbo would not kick in until about 3k and then its a big pull .

all this only started when the fecking service ight came on haha. I was loving the car until all that happend in the last couple of days
 

·
Registered
Joined
·
5,113 Posts
When was the Maf changed last? Discs could be warped by the sounds of it for the braking, My mate had the same problem with the break lights staying on, turn out to be a sticky connection somewhere apparently, or so thats what got passed onto me anyway so don't know anymore, Maf sensor could also cause the light coming on, it needs to be scanned.
 

·
Registered
Joined
·
1,047 Posts
Discussion Starter · #3 ·
Im not sure if it was ever changed i can see kevin is looking at the thread so he might be able to help out.

The car is never driven hard and it was never washed directly after being driven so what would be another reason for the discs? and its only a differnt speeds it not constant.

The brake light is wrecking my head out of everything haha
 

·
Registered
Joined
·
1,357 Posts
Get it scanned and looked at Marty before you start throwing parts at it. I never had to change the maf. It had 69k on it when i bought it in April '07 so could well have the original maf in it. It has the newer green temp sensor so its not that.

There is always a slight vibration due to the grooved discs but if its very bad I'd check the wheel bearings
 

·
Registered
Joined
·
1,047 Posts
Discussion Starter · #5 ·
cheers kevin, yeah this was strange today, my friend had a similer problem in his mk4 and it was a wishbone bushin that was worn. I dont know if its just me thinking if or not but i have noticed my mpg is gone pretty shit lately so hopefully its the maf.

Now this fecking brakes are the worst part

QUOTE (kevinm @ Apr 17 2011, 12:14 AM) <{POST_SNAPBACK}>Get it scanned and looked at Marty before you start throwing parts at it. I never had to change the maf. It had 69k on it when i bought it in April '07 so could well have the original maf in it. It has the newer green temp sensor so its not that.

There is always a slight vibration due to the grooved discs but if its very bad I'd check the wheel bearings
 

·
Registered
Joined
·
12,877 Posts
Sometimes when you get a string of problems like that it can get you down or piss you off but i find if you list them out and tackle them it will soon not seem such a big task.

Like Kevin said scan it and go from there,i wouldn't be surpirsed if the first 2 were related did you fit a genuine brake switch?
 

·
Registered
Joined
·
1,357 Posts
QUOTE (Martymoore @ Apr 17 2011, 12:19 AM) <{POST_SNAPBACK}>cheers kevin, yeah this was strange today, my friend had a similer problem in his mk4 and it was a wishbone bushin that was worn. I dont know if its just me thinking if or not but i have noticed my mpg is gone pretty shit lately so hopefully its the maf.

Now this fecking brakes are the worst part

That might be it too. I fitted TT bushes to the wishbones because they are more durable. They are solid with no voids so look different to normal mk4 bushes.
 

·
Registered
Joined
·
1,047 Posts
Discussion Starter · #8 ·
Is there anything you havnt done to this car haha

QUOTE (kevinm @ Apr 17 2011, 12:30 AM) <{POST_SNAPBACK}>That might be it too. I fitted TT bushes to the wishbones because they are more durable. They are solid with no voids so look different to normal mk4 bushes.
 

·
Registered
Joined
·
12,877 Posts
Marty i am in Dublin tomorrow if you want a scan let me know,i'll be travelling the M50 going north side.
 

·
Registered
Joined
·
1,047 Posts
Discussion Starter · #10 ·
Thanks for the offer shane but im not around at all tomorrow . I will get it done monday
 

·
Registered
Joined
·
1,047 Posts
Discussion Starter · #11 ·
update

Went down to keith in alloy wheels today and he scanned the car for me , what came up was brake switch and something about overboosting(cars remapped), so he said that the light on the dash is prob related to brake switch.

Went down to bradys and bought a brand new switch but the engine workshop warning is coming on still. Does it need to be cleared?
 

·
Registered
Joined
·
1,357 Posts
Did you get this sorted Marty?
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top