Volkswagen Automobiles Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,
The red Coolant warning light keeps appearing on my 2014 Golf GTD. There seems to be a build up of pressure in the system. When I slowly open the cap of the coolant reservoir all the coolant gushes back into the bottle and the level is back to normal. I had it in the garage and they replaced the water pump and EGR valve and coolant reservoir cap but it has made no difference. They are now saying it could be a crack in the head or head gasket. The car is not overheating, there is no signs of water in the oil or oil in the coolant. Any thoughts to what it could be before I put more money into it? Any help would be great. Thanks
 

·
Registered
Joined
·
1 Posts
Hi,
The red Coolant warning light keeps appearing on my 2014 Golf GTD. There seems to be a build up of pressure in the system. When I slowly open the cap of the coolant reservoir all the coolant gushes back into the bottle and the level is back to normal. I had it in the garage and they replaced the water pump and EGR valve and coolant reservoir cap but it has made no difference. They are now saying it could be a crack in the head or head gasket. The car is not overheating, there is no signs of water in the oil or oil in the coolant. Any thoughts to what it could be before I put more money into it? Any help would be great. Thanks
Hello man, have you solved the issue? I have the same problem, MK7 GTD CUNA 2014; the coolant keeps building up pressure; first, the engine "consumed" it, and they said to me it was the head gasked, and have refitted the gasket, they cleaned it, put new water pump, all the distribution was made, new thermostat, even one of the two coolant pumps replaced, cause it was broken, the charge cooler and eger cooler were verified; now it consumed and build up pressure, and the coolant is thrown out of the bowl. When I take the cap off, the pressure still rises the coolant level. Same, the car is not overheating, no water or something , and most of the component were tested. Plus, the cilinder head takes up coolant in time, it was told to me that it inserts coolant in the top of the piston or the cylinder, they found coolant on spark plug, and the car won't start some times.
Have you found the problem with yours? No error comes up on dashboard either on VCDS.
 
1 - 2 of 2 Posts
Top