Volkswagen Automobiles Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,606 Posts
Discussion Starter · #1 ·
Hi lads,

My sister recently fecked off to Australia and left her Canon Powershot SX10IS behind since it's broken and she has some other monster of a camera to jug about with her.
Anyway, the camera stopped working recently before she left (won't power on and no explanation as to why) so Im wondering is there anywhere I could bring it to get it looked at?? If I could get it fixed for relatively cheap, it would leave me with a half decent camera for taking pics at shows or working on cars etc.

Cheers,
Ciaran
 

·
Registered
Joined
·
55 Posts
QUOTE (PaudieG60 @ Apr 18 2011, 10:03 PM) <{POST_SNAPBACK}>Try tapping it off the table,worked for me


This does work sometimes like if there is a tiny bit of grit stuck in the lens or something.

Is it still under warranty by any chance.

Something similiar happened with my camera not so long ago and I got a new model free under warranty.

Or if you're feeling brave you could google some repair guides.
 

·
Registered
Joined
·
1,606 Posts
Discussion Starter · #8 ·
QUOTE (Gaff @ Apr 19 2011, 10:01 PM) <{POST_SNAPBACK}>Stupid question did you try charging batteries (or make sure they are holding charge).

Image Supply Systems in Dublin are Canon repair agents.
http://www.imagesupplysystems.com/news.htm

Yeah tried fresh batteries but no joy unfortunately. I might give them a shout and see what they think, thanks for the help
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top