Volkswagen Automobiles Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all, i have an issue i could do with some advice on...

i have a mk2 caddy van 04 with 65k miles on it, have owned the van for a few months, its been well maintained throughout its life so has a good fuel filter and air filter, coolant/oil has been changed at correct intervals, timing belt and water pump changed, etc etc

recently the engine has started stuttering between 850 and 1500 revs but is fine above 1500. It also starts and idles fine with no smoke or bad diesel smell.

I have a suspicion it might be to do with one or all of the following: EGR valve, MAF senser & MAP sensor. Hopefully they just need cleaning.

Additionally i have noticed erratic behaviour of the coolant temperature. It seems to take a long time to get up to temperature. Once at correct operating temperature it can often drop again, sometimes quite rapidly. Generally, this is a problem at lower speeds, e.g. town driving. If cruising on motorway around 60-70mph it generally stays put in the middle. I'm not sure if this might be part of the same problem with the above-mentioned valves/sensers.

I'm fairly experienced with diesel engines but this is the first vehicle i've owned with this degree of ECU control (all my previous vehicles were pre-2000) so i'm hoping somebody might have some tips for me before i embark on a steep learning curve!

Thanks in advance
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top